1. Introduction
  2. Legal stuff
  3. Use of other software packages
  4. Requirements
  5. Installing & running the program
  6. Features
  7. Basic features (howto)
  8. Menus
  9. Alignment editing tools
  10. Undoable actions
  11. History window
  12. Working with the table
  13. Programs and pipes
  14. Constructing a pipe
  15. Adding new programs
  16. Troubleshooting
  17. Known bugs
  18. Future wishes

1. Introduction

This program was written to make editing RNA alignments easy. The package comes with rnadbtool to analyze the alignment and Pfold for predictions. Pcluster is included for clustering sequences into groups with similar secondary structure. FoldalignM is included for aligning RNA structures.

Details can be found in

Semiautomated improvement of RNA alignments E. S. Andersen, A. Lind-Thomsen, B. Knudsen, S. E. Kristensen, J. H. Havgaard, E. Torarinsson, N. Larsen, C. Zwieb, P. Sestoft, J. Kjems and J. Gorodkin, RNA 13:1850-1859, 2007.

2. Legal stuff

SARSE, Semi-Automated RNA Sequence Editor.
Copyright (C) 2005 The SARSE Team.

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version. This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details. You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.

3. Use of other software packages

This product includes software developed by the Apache Software Foundation (http://www.apache.org/). This license applies to xercesImpl.jar and xml-apis.jar. They are distributed under the Apache Software License. This package includes rnadbtool, Pfold and Pcluster. rnadbtool is written by Bjarne Knudsen, Ebbe Sloth Andersen and Jan Gorodkin and is distributed under GPL. For further information see: rnadbtool. Pcluster and Pfold is written by Bjarne Knudsen. Pcluster: the documentation is distributed along with the program in the directory sarse/programs/pcluster/.

4. Requirements

The application is distributed vith a version for Linux (x86_32) and Mac OS X 10.4 (Intel processor). There is also a source distribution included for other systems.

The requirements of SARSE and the programs toolbox are:

- Sun's JDK/JRE 1.5.0.
- bash
- tcsh
- gawk
- perl
- optional: GD.pm (If not installed you will experience some error messages that can be ignored)

The memory-usage is project dependent because the editor loads the entire alignment in memory. The program can allocate max. 512Mb RAM as default. Actual memory usage for different alignment sizes:
180 sequences, 480 bases: 4Mb
180 sequences, 960 bases: 6Mb
347 sequences, 4000 bases: 53Mb
347 sequences, 6000 bases: 80Mb
94 sequences, 11000 bases: 66Mb
188 sequences, 11000 bases: 106Mb

5. Installing & running the program

The program is developed as a single-user program which means that you should place it somewhere in your home-directory. The projects can be placed anywhere in your home directory including the SARSE subdirectory projects. To install the program, simply unpack the tar-file in your home-directory, or wherever you like. This will create a SARSE directory. The jar-file contains all the nescessary files and directories.

To run the program execute 'SARSE' in the SARSE/bin directory. For easy access to execution from any directory add a path to your environment variables:

PATH=<chosen directory>/SARSE/bin

If you have placed the SARSE directory on your home directory your path should look like this:


To build the source version do the following:

'cd' into <sarse director>/src/programs/rnadbtools/src
run 'make'
'cd' into <sarsedirector>/src/programs/pcluster/src
run 'make'
'cd' into <sarse director>/src/programs/pfold/src
run 'make'
Then you shoul have functional executables for all scripts.
Notice, we haven't gotten pcluster to work on 64bit versions of linux and Mac Powerpc.

6. Features

Split view

Split view splits the screen in two parts (primary and secondary view) that each contains the whole alignment. This easily lets you find pairing or complementary bases by clicking/selecting one/more base(s) in either of the views, e.g. if you click in the primary view, the secondary view will show the pairing/complementary base and vice versa.

When working in split mode you can choose between two selection modes - "single select" or "double select". "Single select" only lets you make selections in the primary view, which means that no complementary or pairing bases are shown in secondary view, while "double select" allows selection in both views.

SARSE remembers the position from where you run a program from the toolbox. If you're currently showing column 100-150 and you run a program, SARSE will go to that same position when showing the resulting file. This unfortunately does not apply for secondary view in split view.


SARSE supports one kind of pairingmasks that consists of any 1-letter code like '1','a' etc. Pairingmasks that contain (, [, {, or > can be used in the double selection mode, but some of the analysis programs does not support this type of pairingmask. The ( and [ can be crossing like in a pseudoknot: ((([[[)))]]].

7. Basic Features (howto)

Here are presented a small selection of how-to's, describing some common tasks. An overview of all features is presented in the next part

Start the program

If you have followed the installation instructions, see doc/install.txt, you can start the editor by simply writing SARSE whereever you are.

The program takes 2 commandline parameters (--file and --project). You can start SARSE on the commandline typing:
    SARSE --file=filename
    where "filename" is the file you want to use in a new project.
    Don't use ~ in the path, use absolute paths
    SARSE --project=projectname
    where "projectname" is the existing project you want to use
    SARSE --project=projectname --file=filename
    If you use both parameters together, a new project will be created using the "filename" and the "projectname", and will be located in the current directory. In this way no further clicking is needed to start working.

Open file/New Projects

SARSE is project oriented which means that every time you open a file a project must be created.

File -> New

This opens a dialog where you are requested to select the file you want to open. When you press 'Open' you are asked for a name of the project and a working directory.
Defaults are provided, default projectname is the name of the file without the filetype-postfix(eg. '.col'). Default working directory is the directory from which you started SARSE. You can accept the defaults or give new ones of your liking. If appropiate the file will be copied to the working directory.

Example: You start a project with a file named HIV1-leader2.txt then the default project name is HIV1-leader2

Open an existing project

If you want to open an existing project,

File -> Open project

Then you get a list of existing projects where you can choose the name of the project you want to open

Delete a project

If you have a project you don't want to work on again delete it

File -> Delete Project

Then you get a list of all your projects and you can choose which one to delete.
You can only delete 1 project at a time, and it is not allowed to delete an open project.

Save file in another location / Export

If you want to save your alignment outside SARSE e.g. if you wan't to use it in another program or want a fasta file

File -> Export File

Then you select a location, write a filename and select a format.

Delete sequences

Select the names of the sequences you want to delete.

Move bases

Bases can be moved in two ways, mouse or buttons.

Mouse: Moves a selection of bases one position at a time.
Select the bases you want to move by left-clicking and dragging. Then move the bases by dragging the selection while holding the right mouse-button down.

Buttons: Moves bases within selection from one end to the other.
Select area, where you want to move the bases from one side to the other.

You can move the bases in the alignment as long as there are gaps to move them into. The whole selection is evaluated together, so if one can't move no one can. Also, it is not allowed to move non-continous blocks of bases.

8. Menus

See also table of menus.


  • New: Keyboard shortcut: Ctrl-N. Creates a new project. First select the alignment file (txt or col format only), then specify project name and where to put the project.
  • Open Project: Keyboard shortcut: Ctrl-O. Opens an existing project.
  • Save Project: Keyboard shortcut: Ctrl-S. Saves the project's current state, including history and properties.
  • Export File: Save current alignment as a col, txt or fasta file.
  • Close: Keyboard shortcut: Ctrl-W. Closes the current project.
  • Delete Project: Keyboard shortcut: Delete. Removes a project from the file system. Remember to export any results first. Note that it is not possible to delete an open project. After a separator line, you will see a list of the projects you are currently working with. Clicking on one will make that project visible.
  • Exit: Keyboard shortcut: Ctrl-Q. Exits the editor.


  • Undo: Keyboard shortcut: Ctrl-Z. Undoes the latest change made in the alignment (if this change is supported by undo - please refer to the section "Undoable actions" for further information).
  • Redo: Keyboard shortcut: Ctrl+Shift-Z. Redoes the latest undone change made in the alignment (if this change is supported by redo - please refer to the section "Undoable actions" for further information).
  • Move Left: Keyboard shortcut: Ctrl-M. Move all gaps in the beginning of the marked area to the back of the marked area.
  • Move Right: Keyboard shortcut: Ctrl+Shift-M. Move all trailing gaps to the front.
  • Change Symbol: Keyboard shortcut: Alt+T. Allows the user to select a new symbol for a marked base name (or a selection of base names).
  • Pair Bases: Keyboard shortcut: Ctrl+B. Pairs two selected bases.
  • Pair Columns: Keyboard shortcut: Ctrl+K. Pairs two selected columns.
  • Go To ..: Asks for a base number in the alignment and moves the view so the number is visible.
  • History: opens a window with the editing history of the project. Please refer to the section "History window" for directions on how to use the history function.


  • Colors: This opens a submenu, where you can select the colors for Text, a, g, u, c and background, sequence name, primary and secondary selection colors. Text is the default textcolor, A, U, G and C are the selected colors when Base Coloring is enabled.
  • Split Mode: Select between Vertical split and horizontal split. Vertical split shows the two tables beside each other. Horizontal split shows one table above the other.
  • Split Screen: Keyboard shortcut: Ctrl-2. Splits the screen.
  • Unsplit Screen: Keyboard shortcut: Ctrl-1. Unsplits the screen.
  • Fonttype: Select a font type from the three fonts bundled with SARSE (Verdana, Arial and Georgia).
  • Fontsize: Select a font size(8-16).
  • Clear Selection(s): Keyboard shortcut: Ctrl+Shift-C. Removes all visible and invisible selections.
  • Fixed Scrolling: If set, the two views in splitview will show the same sequences, they will vertically show the same, but not horizontally. If not set, then the split view will be both horizontally and vertically independent.
  • Base Coloring: If set, the bases will be colored, if not, the symbols will be black
  • Overview: shows a overview of the background coloring of the alignment. Useful after an analysis where some of the programs color the background. The window is interactive, when you click in the overview window the alignment moves to show the area you clicked in.


  • Programs: Keyboard shortcut: F9. Makes an analysis of the current alignment. The result will become the new alignment file for this project.
  • Add Sequences: Keyboard shortcut: Ctrl-D. Adds sequences from another file.
  • Delete Sequences: Keyboard shortcut: Ctrl+Shift-D. Deletes the selected sequences from the alignment. Select sequence names in the left part of the view before deleting.
  • Add Column: Keyboard shortcut: Ctrl-E. Adds a column to all sequences.
  • Remove Column: Keyboard shortcut: Ctrl+Shift-E. Removes a specific column from all sequences.
  • Remove Coloring: Keyboard shortcut: Ctrl+R. Removes the coloring from all sequences.
  • Remove Gaps: Keyboard shortcut: Ctrl-G. Removes all columns that consists of gaps in all sequences.
  • Empty Pairingmask: Keyboard shortcut: Ctrl+F. Clears the pairingmask, leaves no pairings.
  • Fit Alignment to Pairingmask. Force all pairings to be in concordance with the pairingmask.


  • Working directory: Shows the current working directory. If you click on the path it is copied to your system clipboard. This way you can easily copy the path to your shell to see e.g. cluster output.
  • The version and release date are shown.

9. Alignment editing tools

This is a series of icons on the left side of the window.

Manual editing:

  • = Change Symbol. Change the marked symbols to any symbol in the alphabet. This function is also used for editing the pairingmask.

View function:

  • = Split. Splits the current view in two. The behaviour of the two windows are such that the upper/left window is the
    primary view and the other is the secondary view.
  • = Unsplit. Unsplits the current view.

Pairing function:

  • = Unpair Bases: The selected bases, and the bases they pair with, are all shown in lower case.
  • = Pair Bases: The selected base names are changed to upper case if they are within the pairingmask, and a gc, au or gu base pair
  • = Pair Columns: Expands the pairingmask. Asks for a letter/number/parenthesis to use in the pairingmask, and then pairs all cg,au and gu basepairs in the two columns. Works on any equal number of columns. Pairing functions: For all three pairing functions it is the case that when the letters are changed to upper case, the pairings for each sequence is resolved, which means that you have no guaranties that the bases will actually pair when the operation is done.

Select function:

  • = Single Select. Only the selected bases are selected, not the counterparts.
  • = Double Select. Selects not only the selected bases, but also the bases the pair with.

10. Undoable actions

The following actions are supported by undo and redo:
  • Add Column
  • Change Symbols
  • Pair Bases
  • Pair Columns
  • Remove Column
  • Remove Gaps
  • Move Left
  • Move Right
  • Unpair Bases

The undo/redo history is saved with the project, which means that when reopening a project you can still undo/redo past actions.

11. History window

The history window consists of both the files created when running Pfold or RNAdbtool and the actions performed on each file. This way you have an overview of the files contained in your project (this does not apply to Pcluster output or files you add to the project directory) and you can always go back to a previous file by clicking on it in the history window. The file currently displayed on your screen is marked with grey and lists all (undoable) operations you have performed on it underneath. If you click an operation it is undone and the font style is changed to italic so you can easily see, which operations you can redo. Basically the history window shows file view combined with a history. When you use keyboard shortcuts to undo/redo these operations are performed on the file currently displayed. Furthermore it is not possible to undo/redo a file that is not displayed.

12. Working with the table

To mark a single cell, just click on it. To mark an area of cells, hold down the mouse button while you drag it across the table, or mark the first cell and then hold down shift while you expand the area with the arrow buttons on your keyboard. To mark more than one area select one area like above, and then hold down the Ctrl button while you drag the mouse over the next area. Notice that the selected rows always are the same for all selected columns.

13. Programs and pipes

In the Tools menu you can select Programs and a new window opens with a list of programs. You can select any number of programs, but be aware that some programs require execution of other programs. The Programs window provides information about these dependencies, but a rule of thumb is that you can run any RNAdbtool program by itself or combined with other RNAdbtool programs.

Pipeline analyses are provided for some program packages instead of including all subprograms in the SARSE toolbox. The directory sarse/programs/pipes/ contains bash scripts that runs a given number of programs as a default analysis. The files produced are saved in a directory and normally a file is returned for SARSE.

The available program packages are listed to the left. Click one of the packages. The programs contained in the package are listed on the right with a description. If the program has different options an Option button is displayed next to the program name. If you click the Option button you can adjust the parameters. When done press OK and wait.

If any of the programs are sending an error message to the command line a dialog opens and asks if you want to continue. You can choose to see the log message containing the output from the program before continuing. Some programs are sending error messages even though there isn't any fatal error. In any case, view the log message and consider if it looks dangerous.

SARSE is currently distrbuted with the following program packages:


This is a group of programs used to analyse RNA alignments. The following rnadbtools are available in the SARSE toolbox:
  • unknown: Indicates non-standard symbols.
  • shiftchk: Colors all base pairs, so that each base in a pair has the same color.
  • stdpair: Removes/indicates non-standard base-pairs.
  • extendstem: Adds/indicates possible stem extensions.

For more information see: http://rnadbtool.kvl.dk. For reference see: Semi-automated update and cleanup of structural RNA databases, J. Gorodkin, C. Zwieb, and B. Knudsen. Bioinformatics, 17:642-645, 2001.


Pfold is written by Bjarne Knudsen (bk@daimi.au.dk) and makes secondary structure predictions. For reference see: Knudsen, B. and J. J. Hein (1999) Using stochastic context free grammars and molecular evolution to predict RNA secondary structure. Bioinformatics, 15 (6), 446-454. Pfold runs through a pipe (pfold.pipe) using the following programs:
  • findphyl: Finds the phylogeny of the sequences using neighbour joining.
  • mltree: Maximum likelihood of the branch lengths of the phylogenetic tree.
  • scfg: Creates a structure for the alignment.
  • drawphyl: Creates a PostScript file containing the phylogenetic tree in project directory.
  • drawdot: Creates a PostScript file containing a dotplot in project directory.
Pcluster (see below) is a further development of Pfold. Therefore the pfold.pipe uses the programs from the Pcluster package. The pipe has options to specify a region of an alignment in which to do structure prediction. Please note that some output from pcluster.pipe does not appear in SARSE, only the resulting col-file is loaded.


This program clusters sequences into groups with similar secondary structure. For more information see:
Semiautomated improvement of RNA alignments E. S. Andersen, A. Lind-Thomsen, B. Knudsen, S. E. Kristensen, J. H. Havgaard, E. Torarinsson, N. Larsen, C. Zwieb, P. Sestoft, J. Kjems and J. Gorodkin, RNA 13:1850-1859, 2007.
The Pcluster program is run through the pipe pcluster.pipe and has an option to set the region to be analyzed. Please note that some output from pcluster.pipe does not appear in SARSE, only the resulting col-file is loaded.


This program creates a multiple alignment, and create a common pairingmask for the alignment. The input is unaligned sequences. For further information see the http://foldalign.ku.dk

14. Constructing a pipe

A special pipes directory is provided: sarse/programs/pipes, that contains default analyses that runs a given number of programs specified in a bash script. The files produced are saved in a directory and normally a file is returned for SARSE.

The bash script has a specific header that defines the working directory and the programs directory. If you want to create a pipe of your own for SARSE, then use this header. Below commandline execution of the programs are written and the files are written to the work directory.

15. Adding new programs

In the following we assume you know the basic XML syntax. The only prerequisites that must be fullfilled for a program to be added to SARSE is:

  1. It must run under linux/mac
  2. It must read a col-file from std-in
  3. The results must be written to std-out in col-format
  4. It must be in your path
The only thing you must do is edit a XML-file called programs.xml that is located in the "properties" folder in you sarse installation directory.

You insert your program immediately after a </program> tag if you are doubt, place it between these 2 tags: </program> </programs> at the end of the file.


The enclosing tag for each program is a <program> tag it has a few nescessary attributes. Some of them has default values because they are for future extensions. Here is an example from the file:

<program name="stem_colors" priority="7" package="coloring tools" 
selected="false" sequencetype="RNA" type="analyzer" depends="">
The "name" attribute is both the exact name of the command to run the program and the name that is displayed in the menu. "Priority" is for deciding which programs are run first, the lower a number the sooner it is run. The "package" attribute is for grouping the programs in the menu. "Selected" is for a program to be selected by default when you open the program menu. "sequencetype" must be "RNA" and type must be "analyzer", no choice. The "depends" attribute can take the value of the "name" attribute of another program in the xml file. When you select a program in the menu that is dependent on another program that program will also automatically be selected.


The program description has a tag of its own and is added like this:

<program ...>
    Colors stems of alignment in different colors.

Input-output format

You then need to declare the in- and output formats. At the moment this is limited to col-format so you have to add the input-formats and output-formats in the following way:

<program ....>

Adding commandline options

If your program doesn't take commandline options you just insert <parameters/> just before the </program> and you are done.

Options are enclosed in <parameters> tag and each option is placed in a <param>. Each <param> has 3 attributes "selected" is either 'true' or 'false' and decides if the option is selected by default. "Input" is also 'true' or 'false' and decides if the option takes a value, the last, number, must be 0. "spaced" is inserted to tell if there should be a space between the parameter and its values (eg. -r 10 vs. -r10), it takes the values 'true' or 'false'

 <param selected="false" input="false" number="0" spaced=false>
Then you add a <name> tag which should be exactly how the option is used on the commandline, including "-" or "--" if used (eg.).
Then you supply the description
Support information is output as the last entry.
And then end with a closing tag for the option.

Another example is an option that takes an input. Then the input attribute of of the <param> must be true. The difference is an additional <input> tag

<input number="1" delimiter="" description="limit for support">
The "number" attribute tells how many individual values it contains and "delimiter" say what character is used to separate the values. Then there is a "description" attribute and lastly the default-value of the tag. The whole example looks like this:
  <param selected="false" input="true" number="0" spaced="false">
Sets the limit for support. The default is 2/3.
    <input number="1" delimiter="" description="limit for support">

16. Troubleshooting

If you get: Exception in thread "main" java.util.zip.ZipException: No such file or directory when you start the program, it is because the environment variable SARSE_HOME is not pointing to the SARSE directory.

If your jvm runs out of memory e.g. you get a out of memory exception, you can change the maximum memory available in the file bin/SARSE. Look for the line java -Xmx512m -DSARSE_HOME=$SARSE_HOME -jar ../lib/editor.jar. Here you can change the Xmx512m, which means maximum 512 megabytes memory to anything you want. e.g. -Xmx1024m which means maximum 1 gigabytes.

17. Known bugs

Here is a list of known bugs sorted according to priority. Please report newly discovered bugs to info@sarse.kvl.dk.

Editor bugs:

  1. Open fasta bugs
    -When loading a fasta file the following problems occur: can't move a block of residues: can select a block, but only one residue of selected block moves by only one column.
    - "Change the symbol to any symbol..." not working. I can only change eg. a "1" to a "-" but not a "-" to a "1".
    - If there is a pairingmask in the fasta file, then it gets the TYPE=RNA, but should get TYPE=pairingmask.

    Use the test file srprna_ali.fasta.

  2. Double select does not work without a pairingmask
    It should still be possible to double select by the align_bp information from the sequences.

  3. Function keys
    Tools/Programs F9 does not work on Mac since F9 is used for other purposes. Therefore use hat-P instead. Also for "Fit alignment 2 pairingmask" make a function key hat-F.

  4. Error in double select
    When you click "Double select", then the alignment jumps to start. Alignment view position should be preserved.

  5. Jumps to start of alignment
    When working in split view you click on a single strand, which makes the editor jump to start of the alignment. When clicking single strands nothing should happen.

  6. Double select in normal view
    For the alignments without a proper pairingmask you can't use "double select" in normal view, but only in split view. Use the test file mir-399.col.

  7. Export minor bug
    When doing export, then by default no format is selected (the tab is blank). If I just click ok, then nothing happens. It would be best if the default was set to "column format".

  8. Changes in cell area
    There is generally to much space between symbols in the editor window. By setting to Font Size to 8 it gets better. But when running a program then the cell area around the symbols are increased. You have to choose View/Fontsize again to make spacing resonable. Use the test file mir-399.col.

  9. Change symbol does not work
    It doesn't work when loading a file without pairingmask. Change symbol virker ikke, hvis man ikke har en standard pairingmask. Den boer vel virke alligevel.

18. Future wishes

Please send suggestions to info@sarse.kvl.dk. Here is the current list sorted according to priority:
  1. Logging of commands used in the sarse/log directory
    This will support the history function.

  2. New menu icons without text

    menu menu menu menu menu menu menu

  3. The Programs description should also be contained in a button like the Options.
    The description takes up to much space and one gets tired of reading looking at it after having read it the first time!!!

  4. More distance between program name and Options button in Tools/Programs

  5. Add pairingmask
    An Add pairingmask function is needed in the editor. If you import an alignment without pairingmask, then you are not able to annotate it.

  6. Base pairs in the overview window
    Overview should be extended with alistem_plot that shows the correlations between base paired positions.

  7. Tools/Programs program description
    The program description should be put in a "Description" button like the "Options" button. The description is not nessesary after a while.

  8. Drag selection
    Should be more fast, not just move one base at a time. If I drag faster then the selection should move 5-10 positions at a time, depending on the mouse position.

  9. Paringmask
    SARSE should support both "." and "-" in pairingmask. That is both for dragging bases and also for all the executable scripts. "." means single strand and "-" means no prediction. "Fit ali to pm" should make small letters when ".", but do nothing when "-".

  10. "Single select" in right split view
    Selection of unpaired bases in both windows is an important functionality. When you use "extendstem" you want to chose unpaired bases that are far apart. Make split view to look at them and click on the stem that lies just next to to see both sides of the extended stem. Now you want to select the two sides of the extended stem, but when you click on one side, then the other view is automatically reset to the start of the alignment. Here it is important that right view stays put, since it is then easy to chose both sides of single stranded bases.

  11. Run program on selection
    It should be possible to run a given program on a selection in SARSE. If you run Pfold, then you should get an alignment back, that contains an extra pairingmask where "." is the area that was not analysed and "-" is the area where a single strand was predicted.

  12. Clock time names
    Alignment and result files should have the same length of clock-time names.

  13. Removal of table grid
    Option to remove table grid, so there is no space in between base boxes.

  14. Unpair columns
    Menu buttons and tool menu: "Unpair columns", that makes small letters in all of the column and corrects the pairingmask to "-" empty. "Unpair bases", that makes small letters within selection. "Add Pairingmask" in tool menu.

  15. Extended history support
    More History support: "Pair columns" "Add column" "Empty pairingmask"

  16. Pair columns
    If you make "Pair columns" on columns that are already paired, then there should be a warning, that says "These columns are already paired". The way it works now is very laborious: you first type a symbol and then you get more warning boxes.

Comments, questions, etc., email webmaster@sarse.ku.dk.

Last updated November 5th, 2007 by E. S. Andersen, A. Lind-Thomsen and J. Gorodkin